Login to Solsta Client on Windows and Mac is currently down.
Incident Report for Solsta
Resolved
This incident has been resolved.
Posted May 02, 2022 - 21:37 UTC
Update
We are continuing to investigate this issue.
Posted May 02, 2022 - 21:22 UTC
Investigating
We are currently investigating this issue.
Posted May 02, 2022 - 21:22 UTC
This incident affected: Solsta Desktop Authentication.