Outage: Solsta Login
Incident Report for Solsta
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 14:18 UTC
Investigating
We are currently investigating an issue with our entitlement provider which is preventing the ability for users to log into the Solsta Desktop Client.
Posted Jun 20, 2022 - 23:09 UTC
This incident affected: Solsta Desktop Authentication.